This project has moved and is read-only. For the latest updates, please go here.

table DayData not updated at the expected spot-time

Topics: 5. Support
Oct 7, 2014 at 10:19 PM
Today I had a closer look to the data written to the database. I’m working with SBFspot version 3.0.2 installed on a Raspberry Pi and it runs every 5 minutes.
I noticed that the data in view vwSpotData is updated every 5 minutes, but the data in table DayData is not. From the 16 successive times I checked, in four times the DayData was not updated at the expected spot-time, but one spot-time later.
For me this problem is not a big issue. I find it odd, it is wondering me. Is there an explanation? (the deamon?) Am I missing something?
Oct 9, 2014 at 2:26 PM
Check time difference between rpi/inverter and "SynchTime" setting in config (I expect it to be set to "0" - disabled)

For Example:
RPi time is 10:00:00
Inv Time is 09:59:45

Spottime is taken from RPi
Daydata is taken from inverter till 09:55:00

If this time difference is only a few seconds, it's possible it misses only a few times (depends on the time needed to connect to the inverter)

This looks like a bug as there is a config setting "CSV_Spot_TimeSource"=Inverter/Computer for CSV export
For SQL export, there is no such setting and spottime is taken from computer instead of inverter
If you're uploading spotdata such as Uac to PVO, this data will be shifted by 5mins
Oct 9, 2014 at 2:30 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.