ERROR: batch_set_pvoflag() - readonly database

Topics: 5. Support
Oct 22, 2015 at 5:10 PM
Edited Oct 23, 2015 at 1:07 PM
New user since yesterday, using SMA 6000 via speedwire/webconnect. Using RPi and Sqlite3, uploading to my local Domoticz installation and PVoutput.org.

Started fine this morning...at 14.20 it stopped updating. As far as I can understand it did not restart until I did a manual ./SBFspot query from command around 16:15 or so...not sure though. Then it worked on and off until sunset. This is from the upload daemon log...saw these errors yesterday to. What seems to be the problem, database is owned by root and UploadDaemon is run by sudo command. User is pi.

I was suspicious is pvoutput had som issues today because their site was down on and off. But my domoticz also have a static value registered between 14:20 and 16:15....I guess domoticz fetches information locally and not via pvoutput ?

EDIT 2015-10-23: Same thing happened today, it stopped reporting to pvoutput at 14:15, 14:20. When I manually executed "sudo ./SBFspot -v -finq" it all started again...why is this happening ?

EDIT 2 (still 2015-10-23): Found what was causing it to stop at 14:15. My longitude was messed up in cfg file. Sunset was then set to 14:04...

Problem solved, If you guys don't think I need to adjust the readonly database error ?
[14:15:31] INFO: Uploading datapoint: 20151022,14:15,2652517,456,,,42.4,234.24 => OK (200)
[14:20:30] INFO: Uploading datapoint: 20151022,14:20,2652578,732,,,42.3,234.01 => OK (200)
[16:12:31] WARNING: Brunkullas 7.39kW is not yet member of SBFspot Team. Consider joining at http://pvoutput.org/listteam.jsp?tid=613
[16:12:31] WARNING: Brunkullas 7.39kW is not yet member of SBFspot Team. Consider joining at http://pvoutput.org/listteam.jsp?tid=613
[16:15:31] INFO: Uploading 23 datapoints, starting with 20151022,14:25,2652615,444 => OK (200)
[16:30:30] INFO: Uploading 2 datapoints, starting with 20151022,16:20,2653385,48 => OK (200)
[16:30:30] ERROR: batch_set_pvoflag() returned attempt to write a readonly database
Coordinator
Oct 24, 2015 at 10:05 AM
Thanks to report this... I'll try to reproduce this situation.
Oct 24, 2015 at 5:51 PM
Be advised that I did mess up the longitude by pasting the wrong numbers and not checking. The database error though, might not be my fault :)