Upload missing data

Topics: 4. Bugs, 5. Support
May 21 at 1:34 AM
Hi all, over the last week or so I've been getting some strange data uploads to PVOutput. I initially had the issue where the upload was erroring and had to drop one of the view from the database. Once I did that, it sort of started working.

Now I'm getting issue where power is being uploaded, then suddenly stops. After a while it may continue again, but previous data is missing, while energy produced is still being uploaded.

The Daemon logs don't show any issues, it all looks normal.

Here is a sample of the PVoutput data:
https://www.pvoutput.org/intraday.jsp?id=31071&sid=28463

Any suggestions?

Thanks
Coordinator
May 22 at 7:21 AM
Power is limited to approx. 1800 W
Check or post your vwPvoData. It seems you took the example of the workaround without modification.
              CASE WHEN dd.Power > 1800
              THEN 0
              ELSE dd.Power
              END AS V2,

Change the 1800 to 6000 for your system
May 25 at 2:17 AM
Thanks I adjusted the power to 6000, but now I have an error at the end of the script:
Error: no such table: main.vwDayData
Sorry I'm not very good with Databases
Coordinator
May 29 at 9:32 AM
You have dropped the vwDayData view. Recreate it with
CREATE View vwDayData AS
    select datetime(Dat.TimeStamp, 'unixepoch', 'localtime') AS TimeStamp,
    Inv.Name, Inv.Type, Dat.Serial,
    TotalYield,
    Power,
    PVOutput FROM DayData Dat
INNER JOIN Inverters Inv ON Dat.Serial=Inv.Serial
ORDER BY Dat.Timestamp Desc;