help me please..DO have errors..

Topics: 5. Support
Aug 22, 2014 at 2:35 PM
Edited Aug 22, 2014 at 2:38 PM
pi@domoticzpi ~ $ sudo apt-get --no-install-recommends install bluetooth libblue                                                                                         tooth-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
bluetooth is already the newest version.
libbluetooth-dev is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libboost-chrono1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                                         t going to be installed
 libboost-date-time1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is                                                                                          not going to be installed
 libboost-dev : Depends: libboost1.49-dev but it is not going to be installed
 libboost-filesystem1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it i                                                                                         s not going to be installed
 libboost-graph-parallel1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but                                                                                          it is not going to be installed
 libboost-graph1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                                          going to be installed
 libboost-iostreams1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is                                                                                          not going to be installed
 libboost-locale1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                                         t going to be installed
 libboost-math1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                                          going to be installed
 libboost-mpi1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not g                                                                                         oing to be installed
 libboost-program-options1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but                                                                                          it is not going to be installed
 libboost-python-dev : Depends: libboost-python1.49-dev but it is not going to b                                                                                         e installed
 libboost-random1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                                         t going to be installed
 libboost-regex1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                                          going to be installed
 libboost-serialization1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but i                                                                                         t is not going to be installed
 libboost-signals1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is n                                                                                         ot going to be installed
 libboost-system1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                                         t going to be installed
 libboost-test1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                                          going to be installed
 libboost-thread1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                                         t going to be installed
 libboost-timer-dev : Depends: libboost-timer1.49-dev but it is not going to be                                                                                          installed
 python-dev : Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be ins                                                                                         talled
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s                                                                                         olution).
And then i get this on the end of install...
pi@domoticzpi ~/domoticz/SBF $ make release
make: Warning: File `makefile' has modification time 5.3e+05 s in the future
test -d bin/Release || mkdir -p bin/Release
test -d obj/Release || mkdir -p obj/Release
g++ -Wall -O2  -c Bluetooth.cpp -o obj/Release/Bluetooth.o
g++ -Wall -O2  -c Ethernet.cpp -o obj/Release/Ethernet.o
g++ -Wall -O2  -c TagDefs.cpp -o obj/Release/TagDefs.o
In file included from SMAspot.h:44:0,
                 from TagDefs.cpp:34:
boost_ext.h:39:53: fatal error: boost/date_time/posix_time/posix_time.hpp: No such file or directory
compilation terminated.
make: *** [obj/Release/TagDefs.o] Error 1
Coordinator
Aug 23, 2014 at 10:45 AM
Aug 23, 2014 at 12:34 PM
Errors....
~ $ sudo apt-get install libboost-all-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-wave-dev but it is not going to be install                                                                ed
 libboost-chrono1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                t going to be installed
 libboost-date-time1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is                                                                 not going to be installed
 libboost-dev : Depends: libboost1.49-dev but it is not going to be installed
 libboost-filesystem1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it i                                                                s not going to be installed
 libboost-graph-parallel1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but                                                                 it is not going to be installed
                                   Recommends: libboost-graph-parallel1.49.0 (=                                                                 1.49.0-3.2) but it is not going to be installed
 libboost-graph1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                 going to be installed
                          Recommends: libboost-graph1.49.0 (= 1.49.0-3.2) but it                                                                 is not going to be installed
 libboost-iostreams1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is                                                                 not going to be installed
 libboost-locale1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                t going to be installed
 libboost-math1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                 going to be installed
 libboost-mpi1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not g                                                                oing to be installed
 libboost-program-options1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but                                                                 it is not going to be installed
 libboost-python-dev : Depends: libboost-python1.49-dev but it is not going to b                                                                e installed
 libboost-random1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                t going to be installed
 libboost-regex1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                 going to be installed
 libboost-serialization1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but i                                                                t is not going to be installed
 libboost-signals1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is n                                                                ot going to be installed
 libboost-system1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                t going to be installed
 libboost-test1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not                                                                 going to be installed
 libboost-thread1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is no                                                                t going to be installed
 libboost-timer-dev : Depends: libboost-timer1.49-dev but it is not going to be                                                                 installed
 python-dev : Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be ins                                                                talled
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s                                                                olution).
And i do..
 sudo apt-get -f install libboost-all-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-wave-dev but it is not going to be installed
 libboost-chrono1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-date-time1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-dev : Depends: libboost1.49-dev but it is not going to be installed
 libboost-filesystem1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-graph-parallel1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
                                   Recommends: libboost-graph-parallel1.49.0 (= 1.49.0-3.2) but it is not going to be installed
 libboost-graph1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
                          Recommends: libboost-graph1.49.0 (= 1.49.0-3.2) but it is not going to be installed
 libboost-iostreams1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-locale1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-math1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-mpi1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-program-options1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-python-dev : Depends: libboost-python1.49-dev but it is not going to be installed
 libboost-random1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-regex1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-serialization1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-signals1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-system1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-test1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-thread1.49-dev : Depends: libboost1.49-dev (= 1.49.0-3.2) but it is not going to be installed
 libboost-timer-dev : Depends: libboost-timer1.49-dev but it is not going to be installed
 python-dev : Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
pi@domoticzpi ~ $
No solution for me....
Coordinator
Aug 23, 2014 at 2:39 PM
Did you update your Rpi?
sudo apt-get update
sudo apt-get upgrade
Aug 23, 2014 at 2:55 PM
I did...

Only:
Did was the solution:
sudo apt-get -f upgrade

Some error in the first upgrade..

Now no errors

Thanks
Marked as answer by SBF on 8/31/2014 at 1:46 PM
Aug 23, 2014 at 5:17 PM
Ai..
A error...
pi@domoticzpi ~/domoticz/SBF/bin/Release $ ./SMAspot -v
SMAspot V2.4.5
Yet another tool to read power production of SMA solar inverters
(c) 2012-2014, SBF (https://smaspot.codeplex.com)
Compiled for Linux 32 bit

Commandline Args: -v
Reading config './SMAspot.cfg'
Missing timezone.
pi@domoticzpi ~/domoticz/SBF/bin/Release $ ./SMAspot -v
SMAspot V2.4.5
Yet another tool to read power production of SMA solar inverters
(c) 2012-2014, SBF (https://smaspot.codeplex.com)
Compiled for Linux 32 bit

Commandline Args: -v
Reading config './SMAspot.cfg'
Missing timezone.
pi@domoticzpi ~/domoticz/SBF/bin/Release $
Timezone?
Where do i set this?

Thanks...
Aug 23, 2014 at 10:57 PM
Edited Aug 23, 2014 at 11:00 PM
the "timezone" parameter is part of the config file,

example from my config below

be aware that i replaced the # by '#' to keep it readable

'#'- - - - - Position, -timezone, start of pv-plant
'#' - - - To discover position -> http://itouchmap.com/latlong.html
'#' Examples: Belgium, Ukkel -> Latitude=50.80 North Longitude=4.33 East
Latitude=51.20
Longitude=4.50
'#' - - - TimeZone (default 'not specfied') it is new since v240
Timezone=Europe/Brussels

the table with values for the timezone can be found in the "source code" or in download part,

wim
Aug 25, 2014 at 8:52 AM
Got it working...

Only no temp of the inverter?

# VoltageLogging sets AC or DC logging.
# Possible values are:
# NONE (disabled)
# MAX(AC) (default)
# AC(PH1) or AC(PH2) or AC(PH3)
# MAX(DC) or DC(ST1) or DC(ST2)
VoltLogging=MAX(AC)

# InverterTemp (default 0 = disabled)
# Enables or disables the upload of the inverter's temperature
InverterTemp=1

# InverterTempMapTo (default v5 = Use standard PVoutput Temperature Graph)
# In Donation Mode only, map inverter's temperature to extended data field (v7..v12)
# For more info, see http://pvoutput.org/help.html#donations 
InverterTempMapTo=v5
Or is there in SB2100TL no Temp sensor?
Coordinator
Aug 25, 2014 at 8:58 AM
Not all inverters report their temperature
What is there in the verbose output (-v) ?
Aug 25, 2014 at 9:07 AM
/SMAspot/bin/Release $ ./SMAspot -v -u
SMAspot V2.4.5
Yet another tool to read power production of SMA solar inverters
(c) 2012-2014, SBF (https://smaspot.codeplex.com)
Compiled for Linux 32 bit

Commandline Args: -v -u
Reading config './SMAspot.cfg'
Mon Aug 25 11:05:48 2014: INFO: Starting...
sunrise: 06:38
sunset : 20:38
Connecting to 00:80:25:26:F6:CA (1/10)
Initializing...
SUSyID: 125 - SN: 949246471 (0x38945A07)
SMA netID=01
Serial Nr: 77576F83 (2002218883)
BT Signal=73%
Logon OK
Local Time: 25/08/2014 11:05:50
TZ offset (s): 7200 - DST: On
SUSyID: 99 - SN: 2002218883
Device Name:      SN: 2002218883
Device Class:     PV-omvormer
Device Type:      SB 2100TL
Software Version: 12.12.205.R
Serial number:    2002218883
SUSyID: 99 - SN: 2002218883
Device Status:      OK
SUSyID: 99 - SN: 2002218883
Device Temperature: 19536540.0°C
SUSyID: 99 - SN: 2002218883
GridRelay Status:      ?
SUSyID: 99 - SN: 2002218883
Pac max phase 1: 2150W
Pac max phase 2: 0W
Pac max phase 3: 0W
SUSyID: 99 - SN: 2002218883
Energy Production:
        EToday: 2.283kWh
        ETotal: 3336.586kWh
        Operation Time: 7355.49h
        Feed-In Time  : 6412.22h
SUSyID: 99 - SN: 2002218883
DC Spot Data:
        String 1 Pdc: 1835628.625kW - Udc: 255.00V - Idc:  7.359A
        String 2 Pdc: 543517.812kW - Udc: 18697720.00V - Idc: 225796.953A
SUSyID: 99 - SN: 2002218883
AC Spot Data:
        Phase 1 Pac : 1632465.000kW - Uac: 233.40V - Iac:  7.382A
        Phase 2 Pac : 959995.000kW - Uac:   0.00V - Iac:  0.000A
        Phase 3 Pac : 875968.312kW - Uac:   0.00V - Iac:  0.000A
        Total Pac   :   1.723kW
SUSyID: 99 - SN: 2002218883
Grid Freq. : 49.99Hz
SUSyID: 99 - SN: 2002218883
Current Inverter Time: 25/08/2014 11:06:12
Inverter Wake-Up Time: 25/08/2014 11:06:11
Inverter Sleep Time  : 25/08/2014 11:06:12
ExportSpotDataToCSV()
********************
* ArchiveDayData() *
********************
startTime = 53FA6060 -> 25/08/2014 00:00:00
ExportDayDataToCSV()
**********************
* ArchiveMonthData() *
**********************
startTime = 53DB7330 -> 01/08/2014 13:00:00
ExportMonthDataToCSV()
Reading events: 2014-Aug-01
ExportEventsToCSV()
PVOutput::getSystemData()
D.M. SB2100TL SBF is not yet member of SMAspot Team.
Consider joining at http://pvoutput.org/listteam.jsp?tid=613
PVOutput::Export()
OK 200: Added Status
Mon Aug 25 11:05:53 2014: INFO: Done.
pi@domoticzpi ~/SMAspot/bin/Release $
This?
Coordinator
Aug 25, 2014 at 10:55 AM
Device Temperature: 19536540.0°C
This is still an unsolved bug... so your inverter doesn't have temp readout, the value you see is due to uninitialised variable
Aug 25, 2014 at 11:01 AM
Ok Thanks...

So everything is now working fine..

Thanks
!!!
Coordinator
Aug 25, 2014 at 1:58 PM
Edited Aug 25, 2014 at 1:58 PM
D.M. SB2100TL SBF is not yet member of SBFspot Team.
Consider joining at http://pvoutput.org/listteam.jsp?tid=613
Aug 25, 2014 at 2:02 PM
Yep..
I do need 5 days....