no Upload from mysql

Topics: 4. Bugs
Sep 13, 2014 at 3:43 PM
Edited Sep 13, 2014 at 3:44 PM
Hi,

just moving from my old system to some new hardware. Could get everything installed without any problems on Ubuntu 14.04 with mysql (Side Note: in CreateMySQLDB.sql on line 121 there is a select missing in front of convert_tz(from_unixtime(Dat.TimeStamp), 'SYSTEM', '+00:00') AS TimeStamp,).
Only Thing i can't get working is the upload. In the log i see the start note, but thats it. I have no clue how to debug as there is no output at all.

Thanks for any hint!
Coordinator
Sep 13, 2014 at 4:03 PM
Is there something in the db?
select * from vwPvoData;
Sep 13, 2014 at 4:31 PM
Edited Sep 13, 2014 at 4:32 PM
Yes it is populated! the data collecting works like a charm! At the PVoutpu Column it says NULL.
Coordinator
Sep 13, 2014 at 6:56 PM
Edited Sep 13, 2014 at 6:56 PM
Sure about your db connection settings? User/password...
Sep 14, 2014 at 8:38 AM
Yes. Tried root aswell. No change...
Sep 14, 2014 at 1:24 PM
Edited Sep 14, 2014 at 2:02 PM
Hmm seems not related to mysql. Just install squlite and the same thing. Database is populated, but nothing gets uploaded. I rechecked the config and the only thing i am not 100% sure about is the PVoutput SID: i put it like this: PVoutput_SID=1:12345. Is this correct?

Edit: Found the problem: Typo in the serialnumber!
Thanks for the help and keep going! awesome tool!
Coordinator
Sep 14, 2014 at 7:04 PM
Edited Sep 14, 2014 at 7:20 PM
Correct syntax is:
PVoutput_SID=<Serial_Number_Of_Inverter>:<PVO_SID>
If you have 2 inverters, separate them with ','
PVoutput_SID=<Serial_Number_Of_Inverter_1>:<PVO_SID_1>,<Serial_Number_Of_Inverter_2>:<PVO_SID_2>
Marked as answer by SBF on 9/14/2014 at 11:04 AM