Time difference between my correct Raspberry (local dutch) time and the PVOUTPUT site

Topics: 1. General
Feb 21, 2016 at 4:58 PM
Does any know how I can correct the wrong time on the PVOUTPUT site. The PVOUTPUT shows one hour early.
Feb 21, 2016 at 7:50 PM
Edited Feb 21, 2016 at 7:56 PM
dear siem th,

can you please control the settings of the parameter timezone for:
  • your RPi,
  • the configuration-file for SBFspot (sbfspot.cfg)
  • your inverter (might need to use SunnyExplorer = Windows) to control this
  • your PVoutput - subscription
Rational:
  • the software in your inverter (source of the data) is Linux oriented, all data-records get a timestamp in UniversalTimeC
  • the interrogation by SBFspot retrieves the records, stores them in DB-or-csv -> and sends them to PVoutput
  • during the step-by-step data-handling the timestamp of the records is translated to "local time"
For example:
if one of the settings refers to "Greenwhich" in stead of Europe,
then timestamps towards PVoutput will show one hour wrong

if all data is correct,
then execute sbfspot with the debug options and send the resulting output-files

kind regards wim
Coordinator
Feb 23, 2016 at 9:52 AM
Edited Feb 23, 2016 at 9:52 AM
SiemTh wrote:
Does any know how I can correct the wrong time on the PVOUTPUT site. The PVOUTPUT shows one hour early.
Check the timezone at pvoutput on your account/settings page
Feb 23, 2016 at 1:12 PM
Yesterday midday SBFspot went completely dead. I have been unable to get into the directory usr/local/bin/sbfspot.3 to look at SBFspot.cfg.

So now I am rebuilding SBFspot on the Raspberry. If I have the same problem with the time I'll come back.
Feb 23, 2016 at 3:28 PM
Well, I got a complete new SBFspot environment. But the hour difference is still there.

The RPI is one hour off.
SBFspot.cfg time zone is Amsterdam, so ok
Sunny Explorer gives the right time for the inverter
And the time zone on PVOUTPUT is also Amsterdam

How can I correct the time on the RPI? My Linux expertise is non-existent.
Feb 23, 2016 at 3:53 PM
Hi,

In a terminal window enter this:
sudo raspi-config

scroll down using the down arrow key to the "Internationalization Option"
hit the return key
scroll down and select "Change Timezone"
now follow the instructions as presented there.

73
Ron / W4MMP
On 2/23/2016 10:28, SiemTh wrote:

From: SiemTh

Well, I got a complete new SBFspot environment. But the hour difference is still there.

The RPI is one hour off.
SBFspot.cfg time zone is Amsterdam, so ok
Sunny Explorer gives the right time for the inverter
And the time zone on PVOUTPUT is also Amsterdam

How can I correct the time on the RPI? My Linux expertise is non-existent.

Marked as answer by SBF on 2/25/2016 at 12:21 PM
Feb 23, 2016 at 5:33 PM
Edited Feb 24, 2016 at 9:47 AM
Thanks, the time on the RPI is now correct. Tomorrow we'll see about PVOUTPUT.

Next day --> And the time on PVOUTPUT is correct also.