Unable to get readings

Topics: 5. Support
Sep 1, 2016 at 4:45 PM
Edited Sep 1, 2016 at 5:27 PM
Hi,

I have managed to set up the sqlite3 db on Windows, however when I'm trying to get it working and record the readings from the inverter via speedwire but this is what I'm getting

C:\Users\Public\SMAdata>"C:\Program Files (x86)\SBFspot.3\SBFspot" -d -v -finq -
nocsv
SBFspot V3.3.1
Yet another tool to read power production of SMA solar inverters
(c) 2012-2016, SBF (https://sbfspot.codeplex.com)
Compiled for Windows (LE) 32 bit

Commandline Args: -d -v -finq -nocsv
Reading config 'C:\Program Files (x86)\SBFspot.3\SBFspot.cfg'
Thu Sep 01 18:26:27 2016: INFO: Starting...
sunrise: 05:58
sunset : 19:26
Connecting to Local Network...
Initialising Winsock...
Initializing...
SUSyID: 125 - SessionID: 941678870 (0x3820E116)
--------: 00 01 02 03 04 05 06 07 08 09
00000000: 53 4D 41 00 00 04 02 A0 FF FF
00000010: FF FF 00 00 00 20 00 00 00 00
20 Bytes sent to IP [239.12.255.254]
MAX_CommBuf is now 60 bytes
Received 60 bytes from IP [192.168.3.135]
--------: 00 01 02 03 04 05 06 07 08 09
00000000: 53 4D 41 00 00 04 02 A0 00 00
00000010: 00 01 00 02 00 00 00 01 00 04
00000020: 00 10 00 01 00 01 00 04 00 20
00000030: 00 00 00 01 00 04 00 30 C0 A8
00000040: 03 87 00 04 00 40 00 00 00 01
00000050: 00 02 00 70 EF 0C 00 00 00 00
Inverter IP address: 192.168.3.135 found via broadcastidentification
--------: 00 01 02 03 04 05 06 07 08 09
00000000: 53 4D 41 00 00 04 02 A0 00 00
00000010: 00 01 00 26 00 10 60 65 09 A0
00000020: FF FF FF FF FF FF 00 00 7D 00
00000030: 16 E1 20 38 00 00 00 00 00 00
00000040: 01 80 00 02 00 00 00 00 00 00
00000050: 00 00 00 00 00 00 00 00
58 Bytes sent to IP [192.168.3.135]
ethGetPacket()
Received 60 bytes from IP [192.168.3.132]
L2 header not found.
MAX_CommBuf is now 98 bytes
Received 98 bytes from IP [192.168.3.135]
MAX_CommBuf is now 600 bytes
Received 600 bytes from IP [192.168.3.149]
==> packet ignored
Received 600 bytes from IP [192.168.3.149]
==> packet ignored
Received 600 bytes from IP [192.168.3.149]
==> packet ignored
Received 600 bytes from IP [192.168.3.149]
==> packet ignored

The script finds the inverter's IP address but it doesn't continue. I suppose that it could be related with the .cfg file, although I'm not sure. Does have anyone an idea what I'm doing wrong?

Many thanks.
Coordinator
Sep 1, 2016 at 7:48 PM
There are 3 devices involved:
192.168.3.135 -> Inverter
192.168.3.149 -> Sunny Home Manager
192.168.3.132 -> Some other device

Try a direct connection by putting the inveter's IP address in the cfg file (IP_ADDRESS=192.168.3.135)
Coordinator
Sep 9, 2016 at 12:22 PM
Any news on this?